lab-II/shell.nix
2018-03-18 18:02:21 +01:00

23 lines
348 B
Nix

{ pkgs ? import <nixpkgs> {}, mode ? "shell" }:
with pkgs;
let
matplotlib = pythonPackages.matplotlib.override {
enableGtk3 = true;
};
in stdenv.mkDerivation rec {
name = "lab-data";
source = ".";
buildInputs = with pythonPackages; [
matplotlib numpy scipy
sympy uncertainties
];
shellHook = ''
exec fish
'';
}