Lab-I/shell.nix
2016-06-19 20:37:57 +02:00

24 lines
365 B
Nix

{ pkgs ? import <nixpkgs> {}, mode ? "shell" }:
with pkgs;
let
matplotlib = pythonPackages.matplotlib.override {
enableGtk3 = true;
};
in stdenv.mkDerivation rec {
name = "lab-data";
source = ".";
buildInputs = with pythonPackages; [
matplotlib numpy
sympy uncertainties
];
shellHook = ''
#exec 2> /dev/null
exec fish
'';
}