187 lines
4.5 KiB
Nix
187 lines
4.5 KiB
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ # Include the results of the hardware scan.
|
|
./hardware-configuration.nix
|
|
];
|
|
|
|
# System
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.version = 2;
|
|
boot.loader.grub.device = "/dev/sdd";
|
|
|
|
hardware.opengl.driSupport32Bit = true;
|
|
|
|
# SSD
|
|
boot.tmpOnTmpfs = true; # save some writes
|
|
fileSystems."/".options = "discard,noatime";
|
|
|
|
# Mount Data disk
|
|
fileSystems."/mnt/Dati" = {
|
|
device = "/dev/sdd3";
|
|
options = "nofail,relatime,defaults";
|
|
};
|
|
|
|
time.timeZone = "Europe/Rome";
|
|
|
|
virtualisation.virtualbox.host.enable = true;
|
|
|
|
# Networking
|
|
|
|
networking.hostName = "ape";
|
|
networking.hostId = "6bc261fc";
|
|
networking.firewall.enable = false;
|
|
networking.wireless.enable = true;
|
|
networking.connman.enable = true;
|
|
|
|
i18n = {
|
|
consoleFont = "lat9w-16";
|
|
consoleKeyMap = "it";
|
|
defaultLocale = "it_IT.UTF-8";
|
|
};
|
|
|
|
# Packages
|
|
|
|
nixpkgs.config = {
|
|
allowUnfree = true;
|
|
packageOverrides = pkgs: {
|
|
ncmpcpp = pkgs.ncmpcpp.override {
|
|
outputsSupport = true;
|
|
visualizerSupport = true;
|
|
clockSupport = true;
|
|
};
|
|
chromium = pkgs.chromium.override {
|
|
enablePepperFlash = true;
|
|
};
|
|
};
|
|
};
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
# Development
|
|
atom git nodejs
|
|
(haskellPackages.ghcWithPackages (hs: with hs; [ cabal-install ] ))
|
|
# Libs and Tools
|
|
xsel urxvt_perls xclip python34Packages.udiskie encfs
|
|
# Desktop Environment helpers
|
|
dmenu bar i3lock sxhkd
|
|
# Games
|
|
minecraft steam dwarf_fortress
|
|
# Applications
|
|
neovim ranger weechat bc w3m gnupg zathura go14Packages.ipfs.bin
|
|
tmux htop rxvt_unicode pandoc mosh ncdu cv pv tree screenfetch
|
|
scrot iotop iftop
|
|
# Desktop Applications
|
|
chromium libreoffice gparted
|
|
# Media
|
|
beets mpd mpc_cli ncmpcpp popcorntime mpv
|
|
# Drivers, file systems and other compatibility-aimed packages
|
|
ntfs3g exfat utillinuxCurses gptfdisk encfs
|
|
# Other stuff
|
|
];
|
|
|
|
fonts = {
|
|
enableFontDir = true;
|
|
enableGhostscriptFonts = true;
|
|
fonts = with pkgs; [
|
|
gohufont
|
|
];
|
|
};
|
|
|
|
# Services
|
|
|
|
services = {
|
|
|
|
# SSH
|
|
openssh = {
|
|
enable = true;
|
|
permitRootLogin = "no";
|
|
passwordAuthentication = false;
|
|
};
|
|
|
|
# Desktop Environment
|
|
xserver = {
|
|
enable = true;
|
|
videoDrivers = [ "nvidia" ];
|
|
layout = "it";
|
|
windowManager.bspwm.enable = true;
|
|
desktopManager.xterm.enable = false;
|
|
desktopManager.default = "none";
|
|
windowManager.default = "bspwm";
|
|
displayManager.slim.theme = pkgs.fetchurl {
|
|
url = "https://github.com/rnhmjoj/nix-slim/archive/0.2.0.tar.gz";
|
|
sha256 = "08m6ks6crdyr02ll50gy3vpn3rzq6rp5jm2bli526r432xacdmj1";
|
|
};
|
|
};
|
|
|
|
mpd = {
|
|
enable = true;
|
|
user = "fazo";
|
|
group = "users";
|
|
dataDir = "/home/fazo/.config/mpd";
|
|
musicDirectory = "/home/fazo/Music";
|
|
extraConfig = ''
|
|
audio_output {
|
|
type "fifo"
|
|
name "FIFO"
|
|
path "/tmp/mpd.fifo"
|
|
format "44100:16:1"
|
|
}
|
|
audio_output {
|
|
type "alsa"
|
|
name "Fazo-PC"
|
|
mixer_type "software"
|
|
}
|
|
'';
|
|
};
|
|
|
|
redshift = {
|
|
enable = true;
|
|
latitude = "9.6";
|
|
longitude = "45.47";
|
|
};
|
|
|
|
transmission = {
|
|
enable = false;
|
|
settings = {
|
|
download-dir = "/mnt/Dati/Download/";
|
|
};
|
|
};
|
|
|
|
syncthing = {
|
|
enable = true;
|
|
user = "fazo";
|
|
dataDir = "/home/fazo/.config/syncthing";
|
|
};
|
|
};
|
|
|
|
# Custom Services
|
|
|
|
systemd.services.ipfs = {
|
|
after = [ "network.target" ];
|
|
wantedBy = [ "multi-user.target" ];
|
|
path = [ pkgs.bash pkgs.fuse ];
|
|
serviceConfig = {
|
|
User = "fazo";
|
|
ExecStart = "${pkgs.go14Packages.ipfs.bin}/bin/ipfs daemon --init";
|
|
};
|
|
};
|
|
|
|
# User environment
|
|
|
|
programs.zsh = {
|
|
enable = true;
|
|
shellInit = "export ZDOTDIR=~/.config/zsh";
|
|
};
|
|
|
|
users.extraUsers.fazo = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" "transmission" "vboxusers" ];
|
|
uid = 1000;
|
|
shell = "/run/current-system/sw/bin/zsh";
|
|
openssh.authorizedKeys.keys = [ "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDIqHaL0uH1ko/jLI3JeetD4bITUF34IE9HTEvF2Go8JYbhk3YSsG0/EoNu8dhA35S45Y7TXUk/K0axcqmFUePVwY271b7L+9I7/ehUg1wHOaNLCf/ueAyRfo5ZUHuH1YnTg9TinwVi0dynjVMaaVDR1YWVgzuw0KTEDW5em5m+jRbDvFrrq72D2GD/fYqkc2Z/cmnRijMi26PCF1xTq4g6BlIUYloCN+ZlDRvkSWiqCcFD3a/QOZXsUBVg80K4QrHVwj4+Bu2M1KDLhmW+8fzMkbwzKumUFt9SwcQh5Tq/MQfzSWOO2wtn1sys0BDKGazJwn9gMFNkcFbRsD5Uqcgh fazo@mac.lan" ];
|
|
};
|
|
|
|
}
|